大数取模运算

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others

Problem Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

 

Output

For each test case, you have to ouput the result of A mod B.

 

Sample Input

2 3

12 7

152455856554521 3250

 

Sample Output

2

5

1521

 

 

AC的代码:

#include<stdio.h>

#include<string.h>

#include<math.h>

#define MAX 10000

char arr[MAX];

int main()

{

       int n,r,len;

       int i,j;

       while(gets(arr))      //用字符串来接收的数据

       {

              len=strlen(arr);

              j=n=0;

              for(i=len-1;arr[i]!=' ';i--)              //截取被模的数据

              {

                     n=(int)(pow(10,j)*(arr[i]-'0'))+n;

                     j++;

              }

              i=r=0;

              while(arr[i]!=' ')            //进行取模操作

              {

                     r=(r*10+arr[i]-'0')%n;   

                     i++;

              }

              printf("%d/n",r);

              memset(arr,0,MAX*sizeof(char));

       }

       return 0; 

}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值