A1047. Student List for Course

1047. Student List for Course (25)

时间限制
400 ms
内存限制
64000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
 
 
按照正常思路就可以直接做,不过有个坑点,如果直接用string的向量最后一个测试点会超时。
换个思路用char数组来记录名字,让每个i代表一个名字,不过排序规则要自己定义
先看用string的结果,如下图一
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 4e4 + 10;  //学生总数
const int M = 2510;     //课程总数
vector<int> sub[M];     //每门课以int作为向量,每个int 代表char数组名字
char name[N][5];        //char数组和数字映射  

bool cmp(int a, int b){   //按照名字数组字母序升序排规则
  return strcmp(name[a], name[b]) < 0;
}

int main(){
  int n, k;
  scanf("%d %d", &n, &k);
  for(int i = 0; i < n; ++i){
    int num, sub_id;   //num是一个学生选课数  sub_id是学生选课的课程号
    scanf("%s", name[i]);
    scanf("%d", &num);
    for(int j = 0; j < num; ++j){
      scanf("%d", &sub_id);
      sub[sub_id].push_back(i);
    }
  }
  for(int i = 1; i <= k; ++i){
    printf("%d %d\n", i, sub[i].size());
    sort(sub[i].begin(), sub[i].end(), cmp);
    for(int j = 0; j < sub[i].size(); ++j){
      printf("%s\n", name[sub[i][j]]);
    }
  }
  return 0;
}



                                                               图一: string向量做题结果


再看用char数组,结果见下图二

#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 4e4 + 10;  //学生总数
const int M = 2510;     //课程总数
vector<int> sub[M];     //每门课以int作为向量,每个int 代表char数组名字
char name[N][5];        //char数组和数字映射  

bool cmp(int a, int b){   //按照名字数组字母序升序排规则
  return strcmp(name[a], name[b]) < 0;
}

int main(){
  int n, k;
  scanf("%d %d", &n, &k);
  for(int i = 0; i < n; ++i){
    int num, sub_id;   //num是一个学生选课数  sub_id是学生选课的课程号
    scanf("%s", name[i]);
    scanf("%d", &num);
    for(int j = 0; j < num; ++j){
      scanf("%d", &sub_id);
      sub[sub_id].push_back(i);
    }
  }
  for(int i = 1; i <= k; ++i){
    printf("%d %d\n", i, sub[i].size());
    sort(sub[i].begin(), sub[i].end(), cmp);
    for(int j = 0; j < sub[i].size(); ++j){
      printf("%s\n", name[sub[i][j]]);
    }
  }
  return 0;
}



从图中也看出左后一个数据点确实大

总结 :PAT总会有一些大的数据点,面临string和char数组选择综合征的时候,选char数组不会让你有懊恼的感觉。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值