约数个数定理

约数个数定理以及简单的例题

一、约数个数定理的内容

在这里插入图片描述

二、例题:

原题链接

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output
For each test case, output its divisor number, one line per case.

Sample Input
4
12
0

Sample Output
3
6

题意分析:我们把只有2、3、5、7质因数的数称作humble number,要求求出一个humble number的质因数的个数

代码如下:
#include <bits/stdc++.h>
#define ll long long
using namespace std;
int main()
{
	ios::sync_with_stdio(0);
	ll n;
	while(cin >> n)
	{
		ll a[4] = {2, 3, 5, 7};
		ll cnt[4] = {1, 1, 1, 1};
		//the initial value of cnt is 1 because of the formula expression
		if(n == 0) return 0;
		for (ll i = 0; i < 4; i++)
		{
			while(n % a[i] == 0)
			{
				n /= a[i];
				cnt[i]++;
			}
		}
		cout << cnt[0] * cnt[1] * cnt[2] * cnt[3] << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值