3427: Dark roads

http://cs.scu.edu.cn/soj/problem.action?id=3427

Description

Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

Input Specification

The input file contains several test cases. Each test case starts with two numbersm andn, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated bym=n=0. Otherwise,1 ≤ m ≤ 200000 andm-1 ≤ n ≤ 200000. Then follown integer triplesx, y, z specifying that there will be a bidirectional road betweenx andy with lengthz meters (0 ≤ x, y < m andx ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.

Output Specification

For each test case print one line containing the maximum daily amount the government can save.

Sample Input
7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0
Sample Output
51
¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥做了这道题以后感觉自己对kruskal算法又有了一个新的认识,以前的充其量只能
算是模板,真正自己敲得就是这道题了!!嘎嘎!!大笑奖励自己一下!
#include<stdio.h>
#include<iostream>
#include<algorithm>
#define NN 200000000
using namespace std;
struct node
{
int l,r,value;
}g[200005];
int cmp(const node&a,const node&b)
{
return a.value<b.value;
}
int set[200005];
int find(int x)
{
if(x!=set[x])
set[x]=find(set[x]);
return set[x];
}
void merge(int x,int y)
{
int fx,fy;
fx=find(x);
fy=find(y);
if(fx==fy)
return ;
if(fx>fy)
set[fx]=fy;
else
set[fy]=fx;
}
int main()
{
int i,j,k,m,n,x,y,z,ww;
int map[105][105];
while(scanf("%d%d",&m,&n),m,n)
{
for(i=0;i<m;i++)
     set[i]=i;
     ww=0;
for(i=0;i<n;i++)
   {
     scanf("%d%d%d",&g[i].l,&g[i].r,&g[i].value);
     ww+=g[i].value;
     }
sort(g,g+n,cmp);
/*printf("\n");
for(i=0;i<n;i++)
printf("%d %d %d\n",g[i].l,g[i].r,g[i].value);
        printf("\n");*/
int sum=0;
for(i=0;i<n;i++)
{
if(find(g[i].l)!=find(g[i].r))
{
merge(g[i].l,g[i].r);
sum+=g[i].value;
//printf("%d %d %d\n",g[i].l,g[i].r,g[i].value);
}
}
printf("%d\n",ww-sum);
}
return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值