O - 听说下面都是裸题 (最小生成树模板题)

Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?
 

Input

The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 2 31.

Output

For each test case print one line containing the maximum daily amount the government can save.
Sample Input

7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0

Sample Output

51
题解(一个求出修路总和减去最小的花费即可,最小生成树裸题)
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int pre[200005];
struct node{
    int x,y;
   int val;
}road[200005];
int find(int x)
{
    if(x==pre[x])
    return x;
    else
    {
        return pre[x]=find(pre[x]);
    }
}
bool merge (int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        return true;
    }
    else
    {
        return false;
    }
}
bool cmp(node x,node y)
{
    return x.val<y.val;
}
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n))
  {
         if(m==0&&n==0)
         {
             break; 
        } 
        for(int t=0;t<m;t++)
        {
            pre[t]=t;
        }
        long long int sum1=0;
        for(int t=0;t<n;t++)
        {
            scanf("%d%d%d",&road[t].x,&road[t].y,&road[t].val);
            sum1+=road[t].val;
            
        }
        sort(road,road+n,cmp);
        long long int sum=0;
        int cnt=0;
        for(int t=0;t<n;t++)
        {
            if(cnt==m-1)
            break;
            if(merge(road[t].x,road[t].y))
            {
            sum+=road[t].val;
            cnt++;
             }
        }
        if(cnt==m-1)
        {
            printf("%d\n",sum1-sum);
        }
    
  }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值