升级Xcode后VVDocumenter-Xcode不能用的解决办法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zilan1239/article/details/50262203

一,查看Xcode的UUID

方式:在终端执行

$ defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID

拷贝UUID字符串


二,添加Xcode的UUID到VVDocumenter-Xcode的Info.plist文件

1,如果插件已经安装

a,打开xcode插件所在的目录:~/Library/Application Support/Developer/Shared/Xcode/Plug-ins;

b,选择已经安装的插件例如VVDocumenter-Xcode,右键”显示包内容”;

c,找到info.plist 文件,找到DVTPlugInCompatibilityUUIDs的项目,添加一个Item,Value的值为之前Xcode的UUID,保存。


2,如果插件没有安装

a,从GitHub克隆仓库到本地,在Xcode中打开项目,选择项目名称,在TAGETS下选中VVDocumenter-Xcode;
b,选择Info,找到DVTPlugInCompatibilityUUIDs的项目,添加一个Item,Value的值为之前Xcode的UUID;
c,Build项目,VVDocumenter-Xcode会自动安装。
三,重启Xcode
重启Xcode时会提示“Load bundle”、 “Skip Bundle”,这里必须选择“Load bundle”,不然插件无法使用。

没有更多推荐了,返回首页