UVa 1583 Digit Generator 生成元 题解

本文介绍了一个信息学竞赛题目,要求找到给定正整数的最小生成元,即加上其数字之和等于自身的数。通过举例说明了问题,并提供了简单的解题思路,指出可以从较大的数开始枚举以优化性能。给出了样例输入和输出,以及相关的题目链接供参考。
摘要由CSDN通过智能技术生成

英文

Description

For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M
is the digitsum of N, we call N a generator of M.
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of
256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one
generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does
not have any generators, print ‘0’.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

中文

题目大意:

如果x加上x的各个数字之和得到y,就说x是y的生成元。给出n(1<=n<=100000),求最小生成元。无解输出0 。例如,n=216,121,2005时的解分别为198,0,1979 。

提示:

只要枚举就行了。但单纯的枚举容易炸,比如j要从n-45开始,不要从1开始,会快很多。f1是用来求数字和的。代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
int T,n;
bool bo;
int f1(int k)
{
    int ret=0;
    while(k>0)
    {
        ret+=k%10;
        k/=10;
    }
    return ret;
}
int main() 
{
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        bo=0;
        scanf("%d",&n);
        for(int j=n-45;j<=n;j++) if(f1(j)+j==n)
        {
            bo=1;
            printf("%d\n",j);
            break;
        }
        if(bo==0) printf("0\n");
    }
    return 0;
}

相关链接:

UVa题解小全:
https://blog.csdn.net/zj_mrz/article/details/81144019

UVa 1585 Score 得分 题解:
https://blog.csdn.net/zj_mrz/article/details/81144159

UVa 1586 Molar mass 分子量 题解:
https://blog.csdn.net/zj_mrz/article/details/81165988

UVa 10935 Throwing cards away I 卡片游戏 题解:
https://blog.csdn.net/zj_mrz/article/details/81208392

XJOI 3287 离散化 题解:
https://blog.csdn.net/zj_mrz/article/details/81037239

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值