[PAT]1002. A+B for Polynomials (25)


1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2





package go.jacob.day822;

import java.util.Scanner;

public class Demo3 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int count = 0;
		int n1 = sc.nextInt();
		// 上限1000
		double[] res = new double[1001];
		for (int i = 0; i < n1; i++) {
			res[sc.nextInt()] = sc.nextDouble();
		}
		int n2 = sc.nextInt();
		for (int i = 0; i < n2; i++) {
			res[sc.nextInt()] += sc.nextDouble();
		}

		for (int i = 0; i < 10; i++) {
			if (res[i] != 0)
				count++;
		}
		System.out.print(count);
		for (int i = 9; i >= 0; i--) {
			if (res[i] != 0)
				System.out.print(" " + i + " " + res[i]);
		}

	}
}
上面的解答在PAT有一个点无法通过,下面的解答可以AC

package go.jacob.day921;

import java.util.Iterator;
import java.util.Map;
import java.util.Scanner;
import java.util.Stack;
import java.util.TreeMap;

public class Demo1 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		Map<Integer,Double> map=new TreeMap<Integer,Double>();
		int n=sc.nextInt();
		for(int i=0;i<n;i++){
			map.put(sc.nextInt(), sc.nextDouble());
		}
		n=sc.nextInt();
		for(int i=0;i<n;i++){
			int exp=sc.nextInt();
			if(map.containsKey(exp)){
				map.put(exp, map.get(exp)+sc.nextDouble());
			}else{
				map.put(exp, sc.nextDouble());
			}
			//保证输出位数
			map.put(exp, Math.round(map.get(exp)*10)/10.0);
			
			if(map.get(exp)==0)
				map.remove(exp);
		}
		Iterator<Integer> it=map.keySet().iterator();
		Stack<Integer> stack=new Stack<Integer>();
		
		while(it.hasNext()){
			stack.push(it.next());
		}
		
		System.out.print(map.size());
		for(int i=0;i<map.size();i++){
			System.out.print(" "+stack.peek()+" "+map.get(stack.pop()));
		}
		sc.close();
		
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值