[PAT]1031. Hello World for U (20)(Java实现)

1031. Hello World for U (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor


因为字符串长度不超过80,所以n1、n2、n3的长度可以用暴力解法求解


package go.jacob.day1128;

import java.util.Scanner;

/**
 * 
 * @author Administrator
 * 1031. Hello World for U (20)
 */
public class Demo2 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String s = sc.next();
		int num = s.length();
		int n1, n3 = num;
		for (n1 = 2; n1 < num; n1++) {
			n3 = num + 2 - 2 * n1;
			if (n3 < n1) {
				n1--;
				n3 = num + 2 - 2 * n1;
				break;
			}

		}
		int head = 0, tail = num - 1;
		for (int i = 0; i < n1 - 1; i++) {
			for (int j = 0; j < n3; j++) {
				if (j == 0)
					System.out.print(s.charAt(head++));
				else if (j == n3 - 1)
					System.out.print(s.charAt(tail--));
				else
					System.out.print(' ');

			}
			System.out.println();
		}
		for (int j = 0; j < n3; j++) {
			System.out.print(s.charAt(head++));
		}
		sc.close();

	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值