PAT 1031 Hello World for U (20 分) Python

文章目录

题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 n_{1} n1 characters, then left to right along the bottom line with n 2 n_{2} n2 characters, and finally bottom-up along the vertical line with n 3 n_{3} n3 characters. And more, we would like Uto be as squared as possible – that is, it must be satisfied that n 1 = n 3 = m a x ( k ∣ k ⩽ n 2   f o r   a l l   3 ⩽ n 2 ⩽ N ) n_{1}=n_{3}=max\Big(k|k\leqslant n_{2} \space for \space all \space 3 \leqslant n_{2} \leqslant N\Big) n1=n3=max(kkn2 for all 3n2N) with n 1 + n 2 + n 3 − 2 = N . n_{1}+n_{2}+n_{3}-2=N. n1+n2+n32=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

代码

letter = input()
letter_num = len(letter)

if letter_num % 3 == 0:

    n1 = n3 = letter_num // 3

else:

    n1 = n3 = letter_num // 3 + 1

n2 = letter_num + 2 - (n1 + n3)

v1 = letter[:n1]
l2 = letter[n1-1: n1 + n2-1]
v3 = letter[n1 + n2 - 2:]

space = len(l2) -2

for i, j in zip(v1[:-1], v3[::-1][:-1]):
    print(i+' ' * space +j)

print(''.join(l2))

结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值