你需要知道的基础算法知识——STL和基础数据结构(二)

引言

STL是C++的标准模板库,竞赛中很多常用的数据结构、算法在STL中都有,熟练地掌握它们在很多题目中能极大地简化编程。
STL包括容器(container)、迭代器(iterator)、空间配置器(allocator)、配接器(adapter)、算法(algorithm)、仿函数(functor)6个部分。竞赛的重点是STL容器。

2.stack

栈是基本的数据结构之一,特点是“先进后出”。
头文件:#include < stack >
栈的有关操作:

  • stack < Type > s; //定义栈,Type为数据类型,例如int、float等
  • s.push(item); //把item放到栈顶
  • s.top(); //返回栈顶的元素,不会删除
  • s.pop(); //删除栈顶的元素,不会返回
  • s.size(); //返回栈中元素的个数
  • s.empty(); //检查栈是否为空,如果为空,返回true,否则返回false
例题

hdu 1062
Text Reverse
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

AC代码
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int n;
    char ch;
    scanf("%d",&n);
    getchar();
    while(n--){
        stack <char> s;
        while(true){
            ch=getchar();  //一次读入一个字符
            if(ch==' '||ch=='\n'||ch==EOF){
                while(!s.empty()){
                    printf("%c",s.top());  //输出栈顶
                    s.pop();  //清除栈顶
                }
                if(ch=='\n'||ch==EOF) break;
                printf(" ");
            }
            else s.push(ch);  //入栈
        }
        printf("\n");
    }
    return 0;
}
如有错误
欢迎指出

下一篇:你需要知道的基础算法知识——STL和基础数据结构(三)

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值