你需要知道的基础算法知识——STL和基础数据结构(三)

引言

STL是C++的标准模板库,竞赛中很多常用的数据结构、算法在STL中都有,熟练地掌握它们在很多题目中能极大地简化编程。
STL包括容器(container)、迭代器(iterator)、空间配置器(allocator)、配接器(adapter)、算法(algorithm)、仿函数(functor)6个部分。竞赛的重点是STL容器。

3.queue

队列是基本的数据结构之一,特点是“先进先出”。
头文件:#include < queue >
队列的有关操作:

  • queue < Type > q; //定义队列,Type为数据类型,例如int、float等
  • q.push(item); //把item放进队列
  • q.front; //返回队首元素,不会删除
  • q.pop(); //删除队首元素,不会返回
  • q.back(); //返回队尾元素
  • q.size(); //返回元素分数
  • q.empty(); //检查队列是否为空
例题

hdu 1702
ACboy needs your help again!
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor 😦.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output
1
2
2
1
1
2
None
2
3

AC代码
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int t,n,temp;
    cin>>t;
    while(t--){
        string str,str1;
        queue< int > q;
        stack< int > s;
        cin>>n>>str;
        for(int i=0;i<n;i++){
            if(str=="FIFO"){  //队列
                cin>>str1;
                if(str1=="IN"){
                    cin>>temp;
                    q.push(temp);
                }
                if(str1=="OUT"){
                    if(q.empty()) cout<<"None"<<endl;
                    else {
                        cout<<q.front()<<endl;
                        q.pop();
                    }
                }
            }
            else {  //栈
                cin>>str1;
                if(str1=="IN"){
                    cin>>temp;
                    s.push(temp);
                }
                if(str1=="OUT"){
                    if(s.empty())cout<<"None"<<endl;
                    else {
                        cout<<s.top()<<endl;
                        s.pop();
                    }
                }
            }
        }
    }
    return 0;
}
如有错误
欢迎指出

下一篇:你需要知道的基础算法知识——STL和基础数据结构(四)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值