A - Trees on the level(树的层序遍历)

作者:myh

题目描述

    Trees are fundamental in many branches of computer science (Pun definitely intended). Current state-of-the art parallel computers such as Thinking Machines’ CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.
    This problem involves building and traversing binary trees.
    Given a sequence of binary trees, you are to write a pro-gram that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.
    In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k + 1.
    For example, a level order traversal of the tree on the right is: 5, 4, 8, 11, 13, 4, 7, 2, 1.
    In this problem a binary tree is specified by a sequence of pairs ‘(n,s)’ where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of ‘L’s and ‘R’s where ‘L’ indicates a left branch and ‘R’ indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs ‘(n,s)’ as described above separated by whitespace. The last entry in each tree is ‘()’. No whitespace appears between left and right parentheses. All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ‘not complete’ should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

思路:

主要使用了c++ STL中的set。用排序的方法对输入进行排序,根据字符的长度以及相同长度的字典序从小到大,正好对应树从上到下。

注意点:

    1.某些节点无法从根节点出发到达

    2.开始处理数据时都需要清空路径

AC代码

#include<iostream>
#include<string>
#include<set>
#include<algorithm>
using namespace std;
struct Node
{
    string v;
    string path;
};
Node nodes[300];//最多256个结点
set<string>p_set; //主要利用set查找快速的特点
int get_(string s)//找到逗号的下标,找不到返回 -1
{
    int i=0;
    for (i=0; i<s.length(); i++)
    {
        if (s[i]==',')
        {
            return i;
        }
    }
    return -1;
}
bool cmp(const Node& a, const Node& b)
{
    if (a.path.length()!=b.path.length())
    {
        return a.path.length()<b.path.length();//长度小的在前面
    }
    return a.path<b.path;//长度相同的字典序小的在前面
}
int main()
{
    int flag=1;
    int i=0,j;
	string str;
    p_set.clear();//清空
    while (cin >> str)
    {
        if (str!="()")
        {
            j=get_(str);
            if (1)
            {
                nodes[i].v=str.substr(1,j-1);//利用substr函数取出数字和路径
                nodes[i].path=str.substr(j+1,str.length()-j-2);
                if (p_set.find(nodes[i].path)!=p_set.end())
                {
                    flag=0;//某个节点给出超过一次
                }
                else
                {
                   p_set.insert(nodes[i].path);
                }
                i++;
            }
    	}
        else//开始处理一组数据
        {
            if (flag==0)
            {
                cout << "not complete" <<endl;//某个节点给出超过一次
            }
            else
            {
                sort(nodes, nodes+i, cmp);//排序 
                p_set.clear();//清空路径 
                if (nodes[0].path.length()==0)
                {
                   	p_set.insert(nodes[0].path);
                    for (j=1; j<i; j++)
                    {
                        if(p_set.find(nodes[j].path.substr(0,nodes[j].path.length()-1))==p_set.end())
                        {
                            flag=0;//从根到某个叶节点的路径上有的结点没有给出
                        }
                        else
                        {
                           p_set.insert(nodes[j].path);
                        }
                    }
                    if (flag==0)
                    {
                        cout << "not complete" <<endl;//从根到某个叶节点的路径上有的结点没有给出
                    }
                    else
                    {
                        for (j=0; j<i-1;j++)
                        {
                            cout <<nodes[j].v << " ";
                        }
                        cout <<nodes[j].v << endl;
                    }
                }
                else
                {
                    cout << "not complete" <<endl;//没有根节点
                }
            }
            i=0;
            p_set.clear();//清空上一组数据
            flag=1;
        }
  	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值