Trees on the level (二叉搜索树的还原)

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 
 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题意:多组数据,每组数据中包含多个小数据,(x , X)x代表节点值,X代表以根节点开始,向左(L),向右(R)走的路径,每组小数据以()结束。根据这些小数据我们可以恢复一颗完整的二叉搜索树,并按照从上到下,从左至右的顺序输出每个节点的值,如果不能构成一颗树的话,输出“not complete”。

思路:由于每个节点再多有两个儿子,且层数等于走的路径次数+1.因此我们可以把所有的小数据按照层数和字典序排序(L<R),同时每个位置只能出现一次,且子节点必有父节点(子节点的路径减去最后一项)。因此我们要用map记录每个路径出现的次数,判断是否能构建成一棵树。最后根据排序顺序输入对应的节点值或“not complete”。

代码如下:

#include<stdio.h>
#include<string.h>
#include<map>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;

struct node
{
    int x,y; //x为节点值,y为路径位数
    string s;//路径
} mapp[1010];

bool cmp(node a,node b) //排序规则,按照层数,字典序从小到大,
{
    if(a.y==b.y)
        return a.s<b.s;
    return a.y<b.y;
}

int main()
{
    int n=0,flag=0;
    string str;
    map<string,int>v;//记录路径出现次数
    while(cin>>str) //输入多组数据
    {
        int i,num[500];
        if(str=="()")  //一个小数组输入结束
        {
            sort(mapp,mapp+n,cmp);//排序
            if(flag||mapp[0].y!=0) //没有根节点时直接输入 not complete
            {
                printf("not complete\n");
            }
            else
            {

                for(i=0; i<n; i++) //遍历n个小数据
                {
                    if(mapp[i].y>0) //层数大于 1的话
                    {
                        string s;
                        int l=mapp[i].s.size();//路径位数+1
                        for(int j=0; j<l-1; j++) //找此节点的父节点
                            s+=mapp[i].s[j];
                        if(v[s]!=1) //判断是否有父节点
                        {
                            flag=1;
                            break;
                        }

                    }
                    num[i]=mapp[i].x;//记录节点值
                }
                if(flag)
                    printf("not complete\n");
                else
                {
                    for(i=0; i<n; i++) //格式化输出
                    {
                        if(i<n-1)
                            printf("%d ",num[i]);
                        else
                            printf("%d\n",num[i]);
                    }
                }
            }
            n=flag=0;//标记情况
            v.clear(); //情况map,下一组数据还要重新用
            continue;
        }
        //各个小数据
        int x=0,l=str.size();//长度
        for(i=1; i<l; i++)  //计算节点值
        {
            if(str[i]==',')
                break;
            x=x*10+str[i]-'0';
        }
        mapp[n].x=x;  //节点值
        x=0;
        mapp[n].s.clear();
        for(i=i+1; i<l; i++)//将路径放入结构体中
        {
            if(str[i]==')')
            {
                break;
            }
            x++;
            mapp[n].s+=str[i];
        }
        v[mapp[n].s]++;  //记录路径出现次数
        if(v[mapp[n].s]>=2) //出现1次以上就错了
        {
            flag=1;
        }
        mapp[n].y=x; //路径位数
        n++;
    }
    return 0;
}

 

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值