Light, more light UVA10110

 

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output " yes " if the light is on otherwise " no " , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan  
Suman Mahbub  
01-04-2001

一道需要稍微思考的数学题目,题意大概是有n盏灯,一个人要走n趟,在第i趟会把灯的状态取反,求最后第n盏灯的状态。

思路:假设第i趟i能被n整除的话,j=n/i,那么在第j趟又取反,状态不变化,而如果两个数相等的话就会发生变化,就是求这个数是不是平方数了。。

#include<iostream>
#include<cmath>

using namespace std;

int main()
{
    long long n;
    while(cin>>n&&n)
    {
        long long i=static_cast<long long>(sqrt(n));
        if(i*i==n) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值