PAT 1072. Gas Station

思路:最短路径,每次都找出离各个station的最短路径。


注意:虽然不建造某个station,但是和其他house是相通的。


写了好久,但是最后一个用例不通过


1072. Gas Station (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution


#include <iostream>
#include <cstdio>


using namespace std;

char c1[4], c2[4];
int N, M, K, D, d, all;
int dist[1015][1015];

bool has_ans;
int pos;
double mind = 0, avg = 9999999;

int min_dist[1015];
bool marked[1015];

// 符合条件就把has_ans值true
void dijstra(int s) {

    for(int i=1; i<=all; i++) {
        min_dist[i] = 9999999;
        marked[i] = false;
    }

    marked[s] = true;
    for(int i=1; i<=all; i++) {
        if(dist[s][i] != 9999999) {
            min_dist[i] = dist[s][i];
        }
    }

    int k, cnt = all;
    while(--cnt) {
        int temp_min = 9999999;
        for(int i=1; i<=all; i++) {
            if(!marked[i] && min_dist[i] < temp_min) {
                temp_min = min_dist[i];
                k = i;
            }
        }

        marked[k] = true;

//        if(temp_min > D)
//            return;

        for(int i=1; i<=all; i++) {
            //if(i<=N || i==s) {
                if(dist[k][i] != 9999999 && dist[k][i]+min_dist[k]<min_dist[i]) {
                    min_dist[i] = dist[k][i]+min_dist[k];
                }
            //}
        }
    }

    min_dist[s] = 0;
    double cur_min = 9999999, sum = 0;
    for(int i=1; i<=N; i++) {
        if(min_dist[i] > D)
            return;
        if(min_dist[i] > 0 && min_dist[i] < cur_min)
            cur_min = min_dist[i];
        sum += min_dist[i];
    }

    has_ans = true;
    if(cur_min > mind) {
        pos = s;
        mind = cur_min;
        avg = sum/N;
    } else if(cur_min == mind && sum/N < avg) {
        pos = s;
        avg = sum/N;
    } else if(cur_min == mind && sum/N == avg && s < pos) {
        pos = s;
    }

}




int get(char c[]) {
    int p = 0;
    if(c[0] == 'G') {
        for(int i=1; c[i]!='\0'; i++) {
            p = 10 * p + c[i] - '0';
        }
        p += N;
    } else {
        for(int i=0; c[i]!='\0'; i++) {
            p = 10 * p + c[i] - '0';
        }
    }
    return p;
}

int main()
{

    scanf("%d%d%d%d", &N, &M, &K, &D);
    all = N + M;
    for(int i=1; i<=N+M; i++)
       for(int j=1; j<=N+M; j++) {
            dist[i][j] = 9999999;
            dist[j][i] = 9999999;
    }

    for(int i=0; i<K; i++) {
        cin >> c1 >> c2;
        int p1 = get(c1);
        int p2 = get(c2);
        cin >> d;
        dist[p1][p2] = d;
        dist[p2][p1] = d;
    }

    for(int i=N+1; i<=N+M; i++) {
        dijstra(i);
    }

    if(has_ans) {
        cout << "G" << pos - N << endl;
        printf("%.1lf %.1lf", mind, avg);
    } else {
        cout << "No Solution";
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值