PAT 1072. Gas Station (30)(多个点的最短路径)

官网

1072. Gas Station (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution

题目大意


  • 1.给出几个候选加油站,求使:

  • 1.到所有居住点的最近的人家越远越好。
  • 2.到每家每户的平均距离越小越好。
  • 3.如果还相同就取序号最小的。

解题思路

  • 1.对每个加油站dijkstra即可。

AC代码

#include<iostream>
#include<string>
#include<vector>
#include<math.h>
#include<algorithm>
#include<map>
#include<sstream>
#include<cstdio>
using namespace std;
#define INF 0x3f3f3f3f
int n, m, k, ds;
//路径的题,road初始为0
int road[1011][1011];
int visited[1011];
//dist初始为INF
int dist[1011];
void Dijkstra(int now){
    visited[now] = 1;
    for (int i = 1; i <= n + m; i++){
        if (road[now][i] > 0 && dist[now] + road[now][i]<dist[i])
        {
            dist[i] = dist[now] + road[now][i];
        }
    }
    //找到距离距离最短的未访问过的点去访问
    int minDist = INF, minId = -1;
    for (int i = 1; i <= n + m; i++){
        if (visited[i] != 1 && dist[i] < minDist){
            minDist = dist[i];
            minId = i;
        }
    }
    if (minId != -1){
        Dijkstra(minId);
    }
}
struct station{
    int id;
    double sum, per, minDist;
    station(int _id,double _s, double _p, double _m) :id(_id),sum(_s), per(_p), minDist(_m){}
};
bool cmp(const station &a, const station &b){
    if (a.minDist != b.minDist){
        return a.minDist > b.minDist;
    }
    else if (a.per != b.per){
        return a.per < b.per;
    }
    else{
        return a.id < b.id;
    }
}
int main(){
    cin >> n >> m >> k >> ds;
    string w, t; int l, r, v; 
    for (int i = 0; i < k; i++){
        cin >> w >> t >> v;
        if (w[0] == 'G'){
            stringstream ss;
            w = w.substr(1);
            ss << w; ss >> l;
            l += n;
        }
        else{
            stringstream ss;
            ss << w; ss >> l;
        }
        if (t[0] == 'G'){
            stringstream ss;
            t = t.substr(1);
            ss << t;
            ss >> r;
            r += n;
        }
        else{
            stringstream ss;
            ss << t; ss >> r;
        }
        road[l][r] = road[r][l] = v;
    }
    vector<station> keep;
    for (int j = 1; j <= m; j++){
        fill(dist, dist + 1011, INF);
        fill(visited, visited + 1011, 0);
        dist[n + j] = 0;
        Dijkstra(n + j);
        double sum = 0;
        bool isInRange = true;
        double minDist = INF;
        for (int i = 1; i <= n; i++){
            //范围内
            if (dist[i] > ds){
                isInRange = false;
                break;
            }
            //最小距离越大越好
            if (dist[i] > 0 && dist[i] < minDist){
                minDist = dist[i];
            }
            //平均值越小越好
            sum += dist[i];
        }
        if (isInRange){
            keep.push_back(station(j, sum, sum / (double)n, minDist));
        }
    }
    if (keep.empty()){
        cout << "No Solution" << endl;
    }
    else{
        sort(keep.begin(), keep.end(), cmp);
        printf("G%d\n", keep[0].id);
        printf("%.1f %.1f\n", keep[0].minDist, keep[0].per);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值