hdu 1024 Max Sum Plus Plus(最大m字段和)

Max Sum Plus PlusTime Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output

Output the maximal summation described above in one line.
 

Sample Input

     
     
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output

     
     
6 8

Hint

 Huge input, scanf and dynamic programming is recommended. 
         
 

题目大意:

已知有n个数,求m段不相交的子段权值之和最大,

状态转移方程:dp[i][j]表示以i为结尾元素的j个子段的数和

dp[i][j]=max(dp[i-1][j]+s[i],max(dp[1][j-1]--dp[i-1][j-1])+s[i]);

其中max(dp[1][j-1]--dp[i-1][j-1])为结尾元素在1到i-1中字段数为j-1的最大值


for(j=1; j<=m; j++)
{
	mmx=-999999999;
	for(i=j; i<=n; i++)
	{
		dp[i]=max(dp[i-1]+s[i],ans[i-1]+s[i]);//其中dp[i-1]表示的是以i-1结尾的元素j个子段的数和,
ans[i-1]表示的是前i-1个元素中j-1个子段的数和的最大值。
		ans[i-1]=mmx;放在此处是为了实现ans[i-1]+a[i]中a[i]是一个独立的子段,那么此时就应该用的是j-1段
		if(dp[i]>mmx)
		   mmx=dp[i];
	}
	



#include <iostream>
#include <string.h>
using namespace std;
const int nmax = 1000005;
int dp[nmax], s[nmax], ans[nmax];
int main()
{
	int m, n, i, j;
	while(~scanf("%d%d",&m,&n))
	{
		for(i=1; i<=n; i++)
			scanf("%d", &s[i]);
		memset(dp, 0, sizeof(dp));
		memset(ans, 0, sizeof(ans));
		int mmx;
		for(j=1; j<=m; j++)
		{
			mmx=-999999999;
			for(i=j; i<=n; i++)
			{
				dp[i]=max(dp[i-1]+s[i],ans[i-1]+s[i]);
				ans[i-1]=mmx;
				if(dp[i]>mmx)
					mmx=dp[i];
			}
			
		}
		printf("%d\n",mmx);
	}

}
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值