1051. Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
#include <stdio.h>
#define MAXSIZE 1001
int top;                    //指针,始终指向栈顶元素,若栈为空,则为-1 
int main()
{
	int S[MAXSIZE];   //定义数组用作栈 
	int Max,n,k,i,j,m,num,num_max,flag;
	scanf("%d%d%d",&Max,&n,&k);   //依次读取栈的长度,序列中元素的个数,序列的个数 
	for (i=0;i<k;i++)       
	{
		top=-1;              //指针,始终指向栈顶元素,若栈为空,则为-1 
		flag=0;              //开关,初始为0 
		num_max=0;           //一个序列中已经读取到的最大元素,初始化为0 
		for (j=0;j<n;j++)
		{
			scanf("%d",&num); //读取一个元素 
			if (num>num_max)  //如果这个元素比已读取到最大元素还要大
			{
				for (m=num_max+1;m<=num;m++) //最大元素和这个元素之间的元素入栈 
				{
					S[++top]=m;
					if (top+1>Max) //如果入栈过程中超过栈的长度,则不存在这样的序列 
					{
						printf("NO\n");
						flag=1;
						break;
					}
				}
				num_max=num;      //重新将这个元素定义为最大元素 
				if (flag==1) break; 
				top--;
			}else      //如果这个元素比已读取到最大元素小,则将其与栈顶元素相比,看其是不是栈顶元素 
			{
				if (S[top--]!=num)    
				{
					printf("NO\n");
					flag=1;
					break;
				}
			}
		}
		if (flag==0) printf("YES\n");   //如果一个序列的所有元素都符合规则,则输出YES 
		while (j<n-1)     //如果循坏非正常结束,说明此序列不正确,把本序列剩下元素读取完,为下一个序列做准备 
		{
			scanf("%d",&num);
			j++;
		}   
	}
	return 0;
} 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值