由二叉树中序遍历和先序遍历,构造二叉树,经过镜面翻转后输出层次遍历结果

玩转二叉树 

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N\le30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

题目地址:https://www.patest.cn/contests/gplt/L2-011

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <string>
#include <cstring>
#include <sstream>

using namespace std;
struct Btree
{
    int data;
    Btree* left;
    Btree* right;
};
typedef struct Btree Btree;
int zhong[100];
int xian[100];
int n;
int Find(int *zhong,int x,int len)
{
    for(int i=0;i<len;i++)
    {
        if(zhong[i]==x)
        {
            return i;
        }
    }
}

Btree* build(int *zhong,int *xian,int len)
{
    if(len<=0) return NULL;
    Btree *tmp=new Btree;
    tmp->data=xian[0];
    int index=Find(zhong,xian[0],len);
    tmp->left=build(zhong,xian+1,index);
    tmp->right=build(zhong+index+1,xian+index+1,len-index-1);
    return tmp;
}

void Reverse(Btree *root)
{
    if(root==NULL) return;
    Reverse(root->left);
    Reverse(root->right);
    Btree *tmp=root->left;
    root->left=root->right;
    root->right=tmp;
}

int ans[100];
int cur;
queue<Btree*> Q;
void CenOrder(Btree *root)
{
    Q.push(root);
    while(!Q.empty())
    {
        Btree *tmp=Q.front();
        Q.pop();
        ans[cur++]=tmp->data;
        if(tmp->left)
        {
            Q.push(tmp->left);
        }
        if(tmp->right)
        {
            Q.push(tmp->right);
        }
    }
}

int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&zhong[i]);
    }
    for(int i=0;i<n;i++)
    {
        scanf("%d",&xian[i]);
    }
    Btree *root=build(zhong,xian,n);
    Reverse(root);
    CenOrder(root);
    for(int i=0;i<cur;i++)
    {
        if(i==0) printf("%d",ans[i]);
        else printf(" %d",ans[i]);
    }
    printf("\n");
    return 0;
}









  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值