PTA 一元多项式求导 (水题)

7-16 一元多项式求导(20 分)

题目:https://pintia.cn/problem-sets/15/problems/820

设计函数求一元多项式的导数。

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

水题不解释

要注意没有输出的情况,比如输入一个 6 0,答案就是0,应该输出0 0,这点题目没有明说结果为0应该怎么输出。而且题目不是说只输出非0项吗,这。。。

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <vector>
#include <sstream>
#include <map>
#include <queue>
#include <stack>
#include <cstring>
#include <set>
#define INF 1000000
using namespace std;

int main()
{
    int a,b;
    int first=0;
    while(scanf("%d%d",&a,&b)==2)
    {
        if(b==0) continue;
        int x=a*b;
        int y=b-1;
        if(first==0)
        {
            printf("%d %d",x,y);
            first=1;
        }
        else
        {
            printf(" %d %d",x,y);
        }
    }
    if(first==0)
    {
        printf("0 0");
    }
    printf("\n");
    return 0;
}

 

 

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值