poj 2386--Lake Counting

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37283 Accepted: 18532
Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.
Sample Output

3
Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source

USACO 2004 November

解题思路:
采用dfs(深度优先搜索)的方法,先由上到下,由左至右的搜索当搜索到 ‘W’ 时进行dfs,记录下dfs的次数(即为结果)。
在dfs时将此处的 ‘W’ 改为 ‘.’,再进行下一次dfs,以此递归。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
const int MAX = 1E2+10;
char field[MAX][MAX]; 
int N,M;
void dfs(int x,int y)
{
    field[x][y]='.';//将此处'W'改为'.',表示已经搜索过了;
    for(int dx=-1;dx<=1;dx++)
        for(int dy=-1;dy<=1;dy++)
        {
            int xx=x+dx,yy=y+dy;//向四周进行搜索;
            if(xx>=0 && xx<N && yy>=0 && yy<M && field[xx][yy]=='W') dfs(xx,yy);//递归到下一次dfs;
        }
}
int main()
{
    int t=0;
    cin>>N>>M;
    for(int i=0;i<N;i++)
        scanf("%s",field[i]);
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<M;j++)
        {
            if(field[i][j]=='W')
            {
                t++;//记录下dfs的次数,即为结果;
                dfs(i,j);
            }
        } 
    } 
    cout<<t<<endl;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值