An Easy Task

Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
  
  
3 2005 25 1855 12 2004 10000
 

Sample Output
 
2108
1904
43236

 
#include<stdio.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int y,n,i,cnt=0;
		scanf("%d%d",&y,&n);
		for(i=y;;i++)
		{
			if((i%400==0)||(i%4==0&&i%100))
			  cnt++;
			if(cnt==n)
			{
				printf("%d\n",i);
				break;
			}
			  
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C1. Powering the Hero (easy version) time limit per test2 seconds memory limit per test256 megabytes inputstandard input outputstandard output This is an easy version of the problem. It differs from the hard one only by constraints on n and t . There is a deck of n cards, each of which is characterized by its power. There are two types of cards: a hero card, the power of such a card is always equal to 0 ; a bonus card, the power of such a card is always positive. You can do the following with the deck: take a card from the top of the deck; if this card is a bonus card, you can put it on top of your bonus deck or discard; if this card is a hero card, then the power of the top card from your bonus deck is added to his power (if it is not empty), after that the hero is added to your army, and the used bonus discards. Your task is to use such actions to gather an army with the maximum possible total power. Input The first line of input data contains single integer t (1≤t≤1000 ) — the number of test cases in the test. The first line of each test case contains one integer n (1≤n≤5000 ) — the number of cards in the deck. The second line of each test case contains n integers s1,s2,…,sn (0≤si≤109 ) — card powers in top-down order. It is guaranteed that the sum of n over all test cases does not exceed 5000 . Output Output t numbers, each of which is the answer to the corresponding test case — the maximum possible total power of the army that can be achieved.
最新发布
03-05

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值