HDU1076An Easy Task

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19162    Accepted Submission(s): 12243


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
  
  
3 2005 25 1855 12 2004 10000
 

Sample Output
  
  
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 
题目大意: 
题目大意就是说 Ignatius出生在闰年,他什么时候才可以过一个真正的生日,给定一个正整数 Y 代表开始的年份,然后给定一个正整数 N,你的任务就是告诉他从 Y 年开始第 N 个闰年是多少年;
注意:如果Y年是闰年那么从 Y 年开始的第一个闰年就是 Y 年;


分析:
首先我们得知道什么是闰年:
1 能够被4整除的年份,并且不能被100整除的年份为闰年;
2 能够被400整除的年份也为闰年;
然后还有注意题目所给的注意项目,就是如果所给出的年份本身就是闰年,那么他就是从该年开始的第一个年份;

给出AC代码:
#include<iostream>
using namespace std;
int year[1000005];
void YE()
{
	int j = 1;
	for (int i = 4; i < 1000005;)
	{
		if (i % 4 == 0&&i%100!=0)
		{
			year[j] = i;
			//cout << year[j] << endl;
			j++;
		}
		if (i%400==0)
		{
			year[j] = i;
			//cout << year[j] << endl;
			j++;
		}
		i = i + 4;
	}
}
int main()
{
	YE();
	int n, y, x;
	int ed;
	cin >> n;
	while (n--)
	{
		cin >> y >> x;
		for (int i = 0; i < 1000005; i++)
		{
			if (year[i]>=y)
			{
				ed = i;
				break;
			}
		}
		cout << year[ed + x-1] << endl;
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值