Axis 中调用org.apache.axis.enum.Style中的一些参数报错

 
Axis 中调用org.apache.axis.enum.Style中的一些参数报错,org.apache.axis.enum.Style.  cannot  be  resevole type. 
 
Axis 1.2.2版本的 axis.jar 包,客户端生产webservice  client的程序,copy到工程中报错。
 
错误原因:
jdk1.5相对于jdk1.4改进了一些东西,其中之一就是Enum-枚举类型,恰好我们的apache axis1.1中有一个RPC的功能,产生的是包路径下面包含了enum这个单词,这个时候,ecilpse就将他当成了关键字,所以运行是不通过的,解决办法: 
 

 

 资料查看:   

问题原因: 在JDK 1.5及其以上版本中,enum都会被JDK认为是系统关键字,不能作为自定义变量使用。而我的JDK是1.6版本的,因此项目在编译时始终无法通过。

 

解决办法:1、将代码“oper.setStyle(org.apache.axis.enum.Style.RPC);”修改为”oper.setStyle(Style.getStyle("rpc"));“;2、将代码“oper.setUse(org.apache.axis.enum.Use.ENCODED);”修改为“oper.setUse(Use.getUse("encoded")); ”;3、添加代码”import org.apache.axis.constants.Style;
import org.apache.axis.constants.Use;“

 

但这种解决方法不一定适合。

org.apache.axis.enum 与JDK1.5冲突的解决办法

 1、降低JDK的版本1.5以下

 2、采用Axis1.4 及1.4以上的axis.jar版本

--

 

阅读更多
个人分类: WebService
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭