NYOJ 715 Adjacent Bit Counts



Adjacent Bit Counts

时间限制: 1000  ms  |  内存限制: 65535  KB
难度: 4
描述

For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:  

     Fun(011101101) = 3

     Fun(111101101) = 4

     Fun (010101010) = 0

Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy  Fun(x) = p.

 

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100
输出
For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.
样例输入
2
5 2
20 8 
样例输出
6
63426
来源
第六届河南省程序设计大赛
上传者
ACM_赵铭浩


动态规划,表示公式看半天都没看懂,但确实有这么个规律。dp[i][j][0 or 1] ,其中i表示二进制的位数,j 表示 fun(x)的值,最后的 0 or 1 表示该二进制数的最后一位是0 还是 1。dp[i][j][0] = dp[i - 1][j][0] + dp[i - 1][j][1]; j = 0时, dp[i][j][1] = dp[i - 1][j][0];j > 0时,dp[i][j][1] = dp[i - 1][j][0] + dp[i - 1][j][0] 。最后的结果就应该是最后一位是0和1的种数之和。


#include<stdio.h>
#include<string.h>
long long int dp[110][110][2];
//dp[i][j][0]表示fun值为j的i位二进制数的最后一位为0的种数
//dp[i][j][1]表示fun值为j的i位二进制数的最后一位为1的种数 
void fun()
{
	dp[1][0][0] = 1;
	dp[1][0][1] = 1;
	for(int i = 2;i <= 100;i++)
 		for(int j = 0;j < i;j++)
		{
			dp[i][j][0] = dp[i - 1][j][0] + dp[i - 1][j][1];
			dp[i][j][1] = dp[i - 1][j][0];
			if(j > 0)
				dp[i][j][1] += dp[i - 1][j - 1][1];
		} 
}
int main()
{
	memset(dp,0,sizeof(dp));
	fun();
	int k;
	scanf("%d",&k);
	while(k--)
	{
		int n,p;
		scanf("%d%d",&n,&p);
		printf("%lld\n",dp[n][p][0] + dp[n][p][1]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值