hdu 4911 归并排序(求逆序对)

Problem Description

bobo has a sequence a1,a2,…,an. He is allowed to swap two adjacent numbers for no more than k times.

Find the minimum number of inversions after his swaps.

Note: The number of inversions is the number of pair (i,j) where 1≤i<j≤n and ai>aj.

 

Input

The input consists of several tests. For each tests:

The first line contains 2 integers n,k (1≤n≤105,0≤k≤109). The second line contains n integers a1,a2,…,an (0≤ai≤109).

 

Output

For each tests:

A single integer denotes the minimum number of inversions.

 

Sample Input

3 1 2 2 1 3 0 2 2 1

 

Sample Output

1 2

题目大意:交换相邻两数,最多交换k次,输出最小的逆序对数目。

思路 :  先求出所有的逆序对数目。如果小于k,说明所有的逆序对都可以被交换消去,输出0;否则只能消去k个,输出 逆序对数-k。求逆序对用归并排序。

代码如下:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
ll a[maxn],b[maxn],cnt;
void merge(ll l,ll r)
{
	ll mid=(l+r)/2;
	if(l<r)
	{
		//分区间 
		merge(l,mid);
		merge(mid+1,r);
		//合并 
		ll i=l,j=mid+1,t=0;
		while(i<=mid&&j<=r)
		{
			if(a[i]>a[j])
			{
				b[t++]=a[j++];
				cnt+=mid-i+1;//记录逆序对数量 
			}
			else
				b[t++]=a[i++];
		}
		//把剩下的没比较的子序列的数直接加在后面 
		while(i<=mid)
			b[t++]=a[i++];
		while(j<=r)
			b[t++]=a[j++];
		for(int i=0;i<t;i++)//排好序的b[]复制回a[] 
			a[l+i]=b[i];
	}
}
int main()
{
	ll n,k;
	while(~scanf("%lld%lld",&n,&k))
	{
		for(int i=0;i<n;i++)
			scanf("%lld",&a[i]);
		cnt=0;
		merge(0,n-1);
		if(cnt<=k)
			printf("0\n");
		else
			printf("%lld\n",cnt-k);
	}
 } 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值