2015计算机学科夏令营上机考试 H:Falling Leaves BST的插入

Time Limit: 1000MS Memory Limit: 10000K 题目
Total Submissions: 4309 Accepted: 2378
Description

这里写图片描述
Figure 1

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.

A binary tree of letters may be one of two things:
It may be empty.
It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters:
Empty trees are omitted completely.
Each node is indicated by
Its letter data,
A line segment down to the left to the left subtree, if the left subtree is nonempty,
A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.

The preorder traversal of a tree of letters satisfies the defining properties:
If the tree is empty, then the preorder traversal is empty.
If the tree is not empty, then the preorder traversal consists of the following, in order
The data from the root node,
The preorder traversal of the root’s left subtree,
The preorder traversal of the root’s right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:

The root’s data comes later in the alphabet than all the data in the nodes in the left subtree.

The root’s data comes earlier in the alphabet than all the data in the nodes in the right subtree.

The problem:

Consider the following sequence of operations on a binary search tree of letters

Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree

这里写图片描述
by removing the leaves with data

**BDHPY 
CM 
GQ 
K** 

Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.
Input

The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk (‘*’).

The last data set is followed by a line containing only a dollar sign (‘$’). There are no blanks or empty lines in the input.
Output

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.
Sample Input

BDHPY
CM
GQ
K
*
AC
B
$

Sample Output

KGCBDHQMPY
BAC

思路:
1 本题是要建立一个BST,关键在于得到BST的插入顺序,因为插入顺序不同,得到的BST肯定不同。
2 由于每次插入的地方肯定是叶子节点,故BST总是从最顶层的叶子节点(也就是根节点开始)插入,然后是第二层叶子节点,第三层,,,,(注意这里每一层叶子节点不代表一定在二叉树的同一层!!!
3 题目给出的节点顺序正好是BST叶子节点层次顺序的倒序,故先用数组保存所有节点然后从最后一个下标处的值(也就是根节点)开始插入。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<set>
#include<stack>
using namespace std;

struct node
{
    char data;
    node *lchild;
    node *rchild;
}*tree;

void  insert_tree(node *&root,char data)
{
    if(root == NULL)
    {
        root =new node;
        root->data=data;
        root->lchild=NULL;
        root->rchild=NULL;
        return ;
    }
    if(root->data<data) insert_tree(root->rchild,data);
    else insert_tree(root->lchild,data);
}

void preorder(node *root)
{
    if(root==NULL) return ;
    cout<<root->data;
    preorder(root->lchild);
    preorder(root->rchild);
}

int main()
{
    //freopen("input.txt","r",stdin);
   string s,t="";
   while(cin>>s)
   {
       if(s=="*")
       {
           //从后往前建树+continue
           int len = t.length();
           for(int i=len-1;i>=0;i--)
           {
               insert_tree(tree,t[i]);
           }
           preorder(tree);
           cout<<endl;
           //清空
           t.clear();
           tree=NULL;
           continue;
       }
       else if(s=="$")
       {
           //从后往前建树+break
           int len = t.length();
           for(int i=len-1;i>=0;i--)
           {
               insert_tree(tree,t[i]);
           }
           preorder(tree);
           break;
       }
       //保存输入串
       t+=s;
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值