swust oj 413

Quicksort is a well-known sorting algorithm developed by C. A. R.

Hoare that, on average, makes Θ(n log n) comparisons to sort n items. However, in the worst case, it makes Θ(n2) comparisons. Typically, quicksort is significantly faster in practice than other Θ(n log n) algorithms, because its inner loop can be efficiently implemented on most architectures, and in most real-world data it is possible to make design choices which minimize the possibility of requiring quadratic time.

Quicksort sorts by employing a divide and conquer strategy to divide a list into two sub-lists.

The steps are:

1. Pick an element, called a pivot, from the list.

2. Reorder the list so that all elements which are less than the pivot come before the pivot and so that all elements greater than the pivot come after it (equal values can go either way). After this partitioning, the pivot is in its final position. This is called the partition operation.

3. Recursively sort the sub-list of lesser elements and the sub-list of greater elements. The base case of the recursion are lists of size zero or one, which are always sorted. The algorithm always terminates because it puts at least one element in its final place on each iteration (the loop invariant).

Quicksort in action on a list of random numbers. The horizontal lines are pivot values. Write a program to sort ascending int number by QuickSort ,n less than 50000.

输入
 

two lows, the first low is numbers , less and equal than 50000. the second low is a set integer numbers

输出
 

a set integer numbers of sort ascending

样例输入复制
10
4 2 1 5 7 6 9 8 0 3
样例输出复制
0 1 2 3 4 5 6 7 8 9
#include <iostream>
using namespace std;
#include "vector"

// 快速排序 左右分别再排一下
// 核心是要递
void quickSortArr(std::vector<int> &arr, int begin ,int end) {
    int l = begin;
    int r = end;
    if(l >= r) {
        return;
    }

    int val = arr[l]; //  中心值

    while (l < r) {
        while (l < r && arr[r] >= val) {
            r--;
        }
        // 判断交互条件
        if(l < r) {
            arr[l] = arr[r];
        }
        while (l < r && arr[l] <= val) {
            l++;
        }
        if(l < r) {
            arr[r] = arr[l];
        }

        if(l == r) {
            arr[l] = val;
            break;
        }
    }

    quickSortArr(arr,begin,l-1); // 左
    quickSortArr(arr,r+1,end); // 右
}
// 快速排序
int main() {
    int n;
    cin >> n;
    std::vector<int> arr;
    for (int i = 0; i < n; ++i) {
        int a;
        cin >> a;
        arr.push_back(a);
    }

    quickSortArr(arr,0,n - 1);

    for (int i = 0; i < arr.size(); ++i) {
        cout << arr[i] << " ";
    }
    cout << endl;
    return 0;
}

  • 11
    点赞
  • 21
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值