hdu 5762 Teacher Bo

Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked  N  points in the map,the  i -th point is at  (Xi,Yi) .He wonders,whether there is a tetrad  (A,B,C,D)(A<B,C<D,ACorBD)  such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print "YES",else print "NO".
 

Input
First line, an integer  T . There are  T  test cases. (T50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates. (N,M105) .

Next N lines, the  i -th line shows the coordinate of the  i -th point. (Xi,Yi)(0Xi,YiM) .
 

Output
T  lines, each line is "YES" or "NO".
 

Sample Input
  
  
2 3 10 1 1 2 2 3 3 4 10 8 8 2 3 3 3 4 4
 

Sample Output
  
  
YES NO

直接暴力

注意到曼哈顿距离只有 O(M)O(M) 种,根据鸽笼原理,上面的算法在 O(M)O(M) 步之内一定会停止.所以是可以过得.

一组数据的时间复杂度 O(\min{N^2,M})O(min{N2,M}) .

数组要开大!!!!。。错哭了。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<queue>
#define INF 99999999;

using namespace std;
int ABS(int x){
   if(x<0)return -x;
   return x;
}
struct node{
  int x,y;
}a[200005];

int main(){
    int t,n,s;
    int v[200005];
    scanf("%d",&t);
    while(t--){
        int flag=0;
        memset(v,0,sizeof(v));
        scanf("%d%d",&n,&s);
        for(int i=0;i<n;i++){
            scanf("%d%d",&a[i].x,&a[i].y);
        }
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                int m=ABS(a[j].y-a[i].y)+ABS(a[j].x-a[i].x);
                v[m]++;
                if(v[m]>=2) {
                    printf("YES\n");//printf("%d~\n",m);
                    flag=1;break;
                }
            }
            if(flag) break;
        }
        if(!flag)
            printf("NO\n");
    }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值