hdu 5763 Another Meaning

Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 


Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.


Limits
T <= 30
|A| <= 100000
|B| <= |A|


 


Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 


Sample Input
4
hehehe
hehe
woquxizaolehehe
woquxizaole
hehehehe
hehe
owoadiuhzgneninougur
iehiehieh
 


Sample Output
Case #1: 3
Case #2: 2
Case #3: 5
Case #4: 1


Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”.
In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.


这道题,可以用kmp 也可以用哈希,也可以都不用。
主要是dp。
下面是不用kmp地方法。//string a=s.substr(0,5);   获得字符串s中 从第0位开始的长度为5的字符串//默认时的长度为从开始位置到尾
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;


#define LL long long
#define N 100005
#define mod 1000000007


string a,b;
LL dp[100005];
int main()
{
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        cin>>a>>b;
        int len = a.length();
        int len2 = b.length();
        dp[0]=1;
        for(int i=1;i<=len;i++)
        {
            dp[i] = dp[i-1];
            if(i>=len2 && a.substr(i-len2,len2)==b)
                dp[i] = ( dp[i] + dp[i-len2] ) % mod;
        }
        printf("Case #%d: %I64d\n",cas,dp[len]);
    }




    return 0;
}


下面是用kmp方法这个我错了两天,数组开的小最后,真的快哭了


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;

#define LL long long
#define N 200005
#define mod 1000000007

string a,b;
LL dp[N],maxx;
int v[N];
int Next[N],idx[N];
void MakeNext(int m)
{
    Next[0]=-1;
    int i=0,j=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            ++i,++j;
            Next[i]=j;
        }
        else j=Next[j];
    }
}
int KMP(int n,int m)  //a是主串,b是模式串,n是主串长,m是模式串长
{
    MakeNext(m);
    int i=0,j=0,ret=0;dp[0]=1;
    while(i<n)
    {
        if(a[i]==b[j]||j==-1)++i,++j,dp[i]=dp[i-1];
        else j=Next[j];
        //printf("%d=%d\n",i,dp[i]);
        if(j==m&&i>=m)
        {
            v[i-m]=1;
            idx[ret++] = i-m; //各匹配到的模式串在主串中的首字母位置
            j=Next[j];  //允许在主串中重叠查找
            //j=0;  不允许重叠
            if(!v[i])
                dp[i]=(dp[i]+dp[i-m])%mod;
            else
                dp[i]=(dp[i]+dp[i-m-1])%mod;
            //if(dp[i]>maxx) maxx=dp[i];
        }
    }
    return ret; //成功匹配次数
}
//string a=s.substr(0,5);   获得字符串s中 从第0位开始的长度为5的字符串//默认时的长度为从开始位置到尾
int main()
{
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        cin>>a>>b;
        maxx=1;
        int len = a.length();
        int len2 = b.length();
        memset(v,0,sizeof(v));
        KMP(len,len2);
        //for(int i=0;i<=len;i++)
        //    printf("%d ",dp[i]);
        //printf("\n");
        printf("Case #%d: %I64d\n",cas,dp[len]);
    }


    return 0;
}



 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值