HDU1150-Machine Schedule

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
 
推荐指数:※※※
这道题目关键是要对问题进行抽象,提取出问题的关键要素。
题目中只有AB两台机器,每一个机器分别都有若干种工作模式。现在来了k个任务,每个任务只能由A或B的某几种模式完成。
机器在是用不同模式的时候,需要重启,问题是:是重启次数最少。
现在把任务看着做是连接A、B不同工作模式的边,那问题就转变成了,使用最少点(工作模式)覆盖所有的边(任务)。
这其实就是一个最小顶点覆盖问题: http://blog.csdn.net/zhu_liangwei/article/details/11488809
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
const int N=101;
int adj[N][N];
int find(int index,int *visited,int *link){
	int i;
	for(i=1;i<=adj[index][0];i++){
		if(visited[adj[index][i]]==false){//vector is not in augmentation
			visited[adj[index][i]]=true;
			if(link[adj[index][i]]==-1||find(link[adj[index][i]],visited,link)==true){
				link[adj[index][i]]=index;
				return true;
			}
		}
	}
	return false;
}
int hungar(int n){
	int i,count=0;
	int visited[N],link[N];
	memset(link,-1,sizeof(link));
	for(i=0;i<n;i++){
		memset(visited,0,sizeof(visited));
		if(find(i,visited,link)==true)
			count++;
	}
	return count;
}
int main()
{
	int n,m,k;
	while(scanf("%d",&n)&&n!=0){
		scanf("%d%d",&m,&k);
		int i;
		memset(adj,0,sizeof(adj));
		for(i=0;i<k;i++){
			int tas,a,b;
			scanf("%d%d%d",&tas,&a,&b);
			if(a!=0&&b!=0){
				adj[a][++adj[a][0]]=b;
			}
		}
		int times=hungar(n);
		printf("%d\n",times);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值