HDU The Last Practice

The Last Practice

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input

Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output

For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1
<div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div>
60=2^2*3^1*5^1
</div>

Author

lcy

Source

杭电ACM集训队训练赛(IV)
这道题大意是把数分割成若干个质数相乘,我第一时间想到的是先用函数把1~65536的质数求出来放在数组里然后在用循环求每个质数的个数,结果悲剧的Tle。我好恨Tle但一想暴力总是解决不了问题。然后就在循环中把要用到的质数求出来,提交发现Runtime Error(ACCESS_VIOLATION)数组开小了Orz,再改发现Presentation Error。真是一波三折!
AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int i;
int fun(){
    i++;
    int k=2;
    while(k<i){
        if(i%k==0)fun();
        k++;
    }
    return i;

}
int main(){
    int n,count1=0,in=0;
    while(scanf("%d",&n)&&n>0){
        if(in>0)
        putchar('\n');
        printf("Case %d.\n",++count1);
        int p[65536],count=0,out[65536];
        for(i=2;i<65536&&n!=1;i=fun()){
           int  k=0;
            while(n%i==0){
                n/=i;
                k++;
                }
                p[count]=i;
                out[count++]=k;
        }
        for(i=0;i<count;i++)
            if(out[i]!=0){
                printf("%d %d ",p[i],out[i]);
            }
            putchar('\n');
            in++;
    }
    return 0;
}

运行结果:
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值