hdu 1405(水题,格式,分解质因子)

Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.
Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
Input
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.
Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
Sample Input
60
12
-1
Sample Output
Case 1.
2 2 3 1 5 1
Case 2.
2 2 3 1
Hint
60=22*31*5^1
说句实话,这个题没啥技术含量,不过我在这里弄了好半天,一开始是循环结束的条件没有判断好,然后就一直循环,呜呜呜。弄好了就提交,一直显示格式错误,fuck。这个题的本意绝对不是分解质因子,就是想搞一搞我们,yyy。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int n;

int main()
{
	int k=0;
	while(cin>>n,n>1)
	{
		int x=n;
		if(k) cout<<endl;
		printf("Case %d.\n",++k);
		int t=2;
		int count=0;
		while(x)
		{
			if(x%t==0)
			{
				x/=t;
				count++;
			}
			else
			{
				if(count) 
				cout<<t<<" "<<count<<" ";
				if(x==1) break;
				t++;
				count=0;
			}
		}
		cout<<endl;
	}
}

努力加油a题啊,ヾ(◍°∇°◍)ノ゙

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值