HDU I Hate It 线段树单点更新

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 54533    Accepted Submission(s): 21352


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
  
  
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 

Author
linle
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1698  1542  2795  1540  1255 
 结点保存区间最大值
单点更新与查询
ACcode:
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 222222
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
int t[maxn<<2];
char q[3];
int n,m,x,y,ans;
void creatTree(int st,int left,int right){
    if(left==right){
        rd(t[st]);
        return;
    }
    int m=(left+right)>>1;
    int temp=st<<1;
    creatTree(temp,left,m);
    creatTree(temp+1,m+1,right);
    t[st]=max(t[temp],t[temp+1]);
}
void updata(int st,int pos,int add,int left,int right){
    if(left==right){
        t[st]=add;
        return;
    }
    int m=(left+right)>>1;
    int temp=st<<1;
    if(pos<=m)updata(temp,pos,add,left,m);
    else updata(temp+1,pos,add,m+1,right);
    t[st]=max(t[temp],t[temp+1]);
}
int  qurey(int st,int L,int R,int left,int right){
    if(L<=left&&R>=right){
        return t[st];
    }
    int m=(left+right)>>1;
    int temp=st<<1;
    int ret=0;
    if(L<=m)ret=max(ret,qurey(temp,L,R,left,m));
    if(R>m)ret=max(ret,qurey(temp+1,L,R,m+1,right));
    return ret;
}
int main(){
    while(rd2(n,m)!=EOF){
        MT(t,0);
        creatTree(1,1,n);
       // for(int i=1;i<30;i++)printf("t[%d]   %d\n",i,t[i]);
        FOR(i,1,m){
            rds(q); rd2(x,y);
            if(q[0]=='Q'){
                ans=qurey(1,x,y,1,n);
                printf("%d\n",ans);
            }
            else updata(1,x,y,1,n);
        }
    }
    return 0;
}
/*
5 7
1 2 3 4 5
Q 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值