山东省第一届ACM大学生程序设计竞赛 Greatest Number 二分查找

Greatest Number

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Saya likes math, because she think math can make her cleverer.
One day, Kudo invited a very simple game:
Given N integers, then the players choose no more than four integers from them (can be repeated) and add them together. Finally, the one whose sum is the largest wins the game. It seems very simple, but there is one more condition: the sum shouldn’t larger than a number M.
Saya is very interest in this game. She says that since the number of integers is finite, we can enumerate all the selecting and find the largest sum. Saya calls the largest sum Greatest Number (GN). After reflecting for a while, Saya declares that she found the GN and shows her answer.
Kudo wants to know whether Saya’s answer is the best, so she comes to you for help.
Can you help her to compute the GN?

输入

The input consists of several test cases.
The first line of input in each test case contains two integers N (0<N≤1000) and M(0
 1000000000), which represent the number of integers and the upper bound.
Each of the next N lines contains the integers. (Not larger than 1000000000)
The last case is followed by a line containing two zeros.

输出

For each case, print the case number (1, 2 …) and the GN.
Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

2 10
100
2

0 0

示例输出

Case 1: 8

提示

 

来源

 2010年山东省第一届ACM大学生程序设计竞赛

示例程序

给你n个数让你任意有放回的选0-4个使得最后得到值在小于m的情况下最大

思路把所有可能的情况打表

首先我们打一个表表示选2个情况和一个情况的表,这样需要的空间就是1000*1000

如果把所有的结果打出来是不现实的,这时候对于第二次打表表示取4个的情况,我们可以

枚举表示选2个和一个情况然后在二分后面取的最大的数来求答案

比如样例符合取2个数的表有  2,4

那么我们枚举2,4然后二分查找对于取了2或4对应取第二数最大的情况

ACcode:

#include <bits/stdc++.h>
#define maxn 1011100  
#define eps 1e-8
#define inf 0x3f3f3f
using namespace std;
int n,m,cnt=1;
int dp[maxn];
int main(){
    while(scanf("%d%d",&n,&m)&&n+m){
        int tmp,pos=1;
        for(int i=1;i<=n;++i){
            scanf("%d",&tmp);
            if(tmp<=m)dp[pos++]=tmp;
        }
        int len=pos;
        for(int i=1;i<len;++i)
            for(int j=1;j<len;++j)
                if(dp[i]+dp[j]<=m)
                    dp[pos++]=dp[i]+dp[j];
        sort(dp,dp+pos);
        int ans=0,l,r,mid;
        for(int i=0;i<pos;++i){
            l=0,r=pos;
            while(l<r){
                mid=(l+r)>>1;
                tmp=dp[mid]+dp[i];
                if(tmp<=m){
                    ans=max(ans,tmp);
                    l=mid+1;
                }
                else r=mid;
            }
        }
        printf("Case %d: %d\n\n",cnt++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值