HDU 4734 F(x) 数位 dp

H - F(x)
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

For a decimal number x with n digits (A  nn-1n-2 ... A  21), we define its weight as F(x) = A  n * 2  n-1 + A  n-1 * 2  n-2 + ... + A  2 * 2 + A  1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input

The first line has a number T (T <= 10000) , indicating the number of test cases. 
For each test case, there are two numbers A and B (0 <= A,B < 10  9)
 

Output

For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input

     
     
3 0 100 1 10 5 100
 

Sample Output

     
     
Case #1: 1 Case #2: 2 Case #3: 13
 
 ACcode:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int dp[11][10000];
int data[11];
int cnt=1;
int k;
int dfs(int len,int sum,int limit){
    if(!len)return sum>=0;
    if(sum<0)return 0;
    if(!limit&&dp[len][sum]!=-1)return dp[len][sum];
    int ed=limit?data[len]:9;
    int ans=0;
    for(int i=0;i<=ed;++i)
        ans+=dfs(len-1,sum-i*(1<<(len-1)),limit&&i==ed);
    return limit?ans:dp[len][sum]=ans;
}
void doit(){
    int a,b;
    scanf("%d%d",&a,&b);
    int len=0;
    k=0;
    while(a){
        k+=(a%10)*(1<<len);
        a/=10;
        len++;
    }
    len=0;
    while(b){
        data[++len]=b%10;
        b/=10;
    }
    printf("Case #%d: %d\n",cnt++,dfs(len,k,1));
}
int main(){
    int loop;memset(dp,-1,sizeof(dp));
    scanf("%d",&loop);
    while(loop--)doit();
    return 0;
}
/*
2123
1 23
23 435
43 454
231 2312
100 23
32 421
2312 1223
122 444
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值