hdu 4734 F(x)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2781    Accepted Submission(s): 1029


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source
 


数位DP;dp[pos][sum]:当前位数为pos时,最大值为f(a)时,当前位还剩下sum可以用。

#include<stdio.h>
#include<string.h>
#include<math.h>
int dp[11][5120];
int dight[11],num[11];
int a,b,m;
int dfs(int pos,int sum,int flag)
{
  if(pos==-1)
        if(sum>=0)return 1;
        else return 0;
        if(sum<0)return 0;
        if(!flag&&dp[pos][sum]!=-1)return dp[pos][sum];
        int i,ans=0,u=flag?dight[pos]:9;
        for(i=0;i<=u;i++)
            ans=ans+dfs(pos-1,sum-i*num[pos],flag&&i==u);
            if(!flag)dp[pos][sum]=ans;
            return ans;
}
int fun(int n)
{
    int len=0;
    while(n)
    {
        dight[len++]=n%10;
        n=n/10;
    }
    dfs(len-1,m,1);
}
int main()
{
    int t,i,x;
    scanf("%d",&t);
    for(i=0;i<11;i++)
        num[i]=pow(2,i);
        memset(dp,-1,sizeof(dp));
   for(i=1;i<=t;i++)
    {x=1;m=0;
        scanf("%d %d",&a,&b);
        while(a)
        {
           m=m+a%10*x;
           x=x*2;
           a=a/10;
        }
        printf("Case #%d: %d\n",i,fun(b));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值