HDU 3853 LOOPS 概率dp

E - LOOPS
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 




 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 


 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 

 

Sample Input

       
       
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output

       
       
6.000
 
晓美焰要从(1,1)到(n,n)在每个点都有3种可能 不走 或向右 或向下走  每次花费2个魔法值
求花费的魔法值的期望 求期望都说倒着推
那么每个点的下一个状态可能是右边或下面
那么 dp[i][j]=(dp[i][j+1]*右边的概率+dp[i+1][j]*下面的概率+花费)/(右边+下面的概率)
ACcode:
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 1002
using namespace std;
double dp[maxn][maxn],a[maxn][maxn],b[maxn][maxn],c[maxn][maxn];
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;++i)for(int j=1;j<=m;++j)scanf("%lf%lf%lf",&a[i][j],&b[i][j],&c[i][j]);
        for(int i=n;i>=1;--i)for(int j=m;j>=1;--j)
            if((i==n&&j==m)||(fabs(1-a[i][j])<1e-7))continue;
            else dp[i][j]=(dp[i][j+1]*b[i][j]+dp[i+1][j]*c[i][j]+2)/(b[i][j]+c[i][j]);
        printf("%.3lf\n",dp[1][1]);
    }
}
/*
2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00
*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值