PAT 甲级 1009. Product of Polynomials(模拟)

 

1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

Analysis:

This problem is too easy,just to simulate and what you need to pay attention to is that the highest power may arrive at 2000, so you need to new a big enough array. 

c/c++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	//freopen(".txt","r",stdin);
	double a[1001]={0},b[1001]={0},re[2001]={0},count=0;/*the size of the array(re) need to be at least 2001 to solve the problem. the index denotes the exponent of each item,the value means the coefficient */ 
	int k;
	cin>>k;
	for(int i=0;i<k;i++){
		int ex;
		double co; 
		cin>>ex>>co;
		a[ex]=co;
	}
	cin>>k;
	for(int i=0;i<k;i++){
		int ex;
		double co; 
		cin>>ex>>co;
		b[ex]=co;
	}
	for(int i=0;i<=1000;i++)
		for(int j=0;j<=1000;j++){
			re[i+j]+=a[i]*b[j];
		}
	for(int i=0;i<=2000;i++)
		if(re[i])count++;//count the number of nonzero terms in the polynomial.
	cout<<count;
	for(int i=2000;i>=0;i--)
		if(re[i])
			printf(" %d %.1lf",i,re[i]);
	return 0;
}

 

java:

 

package A1009;

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		double a[]=new double [1001],b[]=new double [1001],re[]=new double [2001];
		int count=0,k;
		Scanner sc=new Scanner(System.in);
		k=sc.nextInt();
		while(k-->0) {
			int ex=sc.nextInt();
			double co=sc.nextDouble();
			a[ex]=co;
		}
		k=sc.nextInt();
		while(k-->0) {
			int ex=sc.nextInt();
			double co=sc.nextDouble();
			b[ex]=co;
		}
		for(int i=0;i<=1000;i++)
			for(int j=0;j<=1000;j++){
				re[i+j]+=a[i]*b[j];
			}
		for(int i=0;i<=2000;i++)
			if(re[i]!=0)count++;
		System.out.print(count);
		for(int i=2000;i>=0;i--)
			if(re[i]!=0)
				System.out.printf(" %d %.1f",i,re[i]);//an output way like c
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值