PAT甲级 - 1009 Product of Polynomials (25 分)

题目链接:PAT甲级 - 1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题解:一开始,测试点3,4总是通不过,原因在于多项式结果数组开小了。以指数作为数组下标,多项式相乘,同底数的指数相加,所以结果数组需要开到2*maxn. 

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn=2010;
double a[maxn],b[maxn],c[maxn];

int main(){
	int t,k1,k2;
	while(~scanf("%d",&k1)){
	 	memset(a,0,sizeof(a));
	 	memset(b,0,sizeof(b));
	 	memset(c,0,sizeof(c));
	 	int mx1=-1,mx2=-1;
	  	for(int i=0;i<k1;i++){
  			scanf("%d",&t);
  			mx1=max(mx1,t);
  			scanf("%lf",&a[t]);
  		}
	  	scanf("%d",&k2);
	  	for(int i=0;i<k2;i++){
	  		scanf("%d",&t);
	  		mx2=max(mx2,t);
  			scanf("%lf",&b[t]);
	  	}
	  	for(int i=0;i<=mx1;i++){
	  		for(int j=0;j<=mx2;j++){
	  			c[i+j]+=a[i]*b[j];
			}
		}
		int cnt=0;
		for(int i=0;i<=mx1+mx2;i++){
			if(c[i]) cnt++;
		}
		printf("%d",cnt);
  		for(int i=mx1+mx2;i>=0;i--){
  			if(c[i])
  				printf(" %d %.1f",i,c[i]);
  		}
  		printf("\n");
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值