POJ2259详细做法及讲解

Team Queue
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 5778
Accepted: 1949

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

心血来潮,写个博客纪念一下我以及其快的做法完成了这道题!

题意:维护一个team queue,每次入队列,如果跟这个元素在一个队里的元素已经在这个大队里,那么这个元素可以插到他们队友的后面。给出有几个队以及这些队里面包含的元素,输出要求出队的时候的元素。

思路:按照题目输入的顺序,给队编号。因为属于同一个队的可以插队,所以在队列中,同一个队的必然在一起。所以一个总的队列,只用记录下来队伍的编号就可以了,再记录下来每个队伍中的顺序。

其实我认为这道题就是队列的基本操作,不需要用什么东西,只需要会入队出队循环输出即可,是非常简单的操作。这里普及一下队列的基本操作:

①进队:queue.push( );

②出队:queue.pop( );

③队头元素:queue.front( );

④队列为空:queue.empty( );

⑤进队进队尾,出队出队头。


//POJ2259
//制作人:zproud
//便于理解的,超级简单的解决方式,运用了队列和数组。 
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
#include <queue>
#define maxn 1010
using namespace std;
bool numgroup[maxn];
int sbzhw[1000000];
int main()
{
//	freopen("text.in","r",stdin);
//	freopen("text.out","w",stdout); 
    int T,n,a,t=0;
    while(~scanf("%d",&T))//while(~)的意思就是无限输出和while(1){scanf}一样的道理,我懒所以这样写。
     if(T==0){break;
			}
			else
    {
        queue<int>team[maxn];//队列 
        queue<int>q;
//        memset(numgroup,0,sizeof(numgroup));此处本来想可以利用初始化优化,然并卵。
//        memset(sbzhw,0,sizeof(sbzhw));
        for(int i=1; i<=T; i++)
        {
            scanf("%d",&n);
            while(n--)
            {
                scanf("%d",&a);
                sbzhw[a]=i;
            }
        }
         printf("Scenario #%d\n",++t);
        char command[200];
        while(~scanf("%s",command))
        {
            if(command[0]=='S')
          {
              break;
            }
            if(command[0]=='E')
            {
                int ren,b;
                scanf("%d",&ren);
                b=sbzhw[ren];
                
                if(team[b].empty())
                {
                    q.push(b);
                    team[b].push(ren);
                }
                else 
                	team[b].push(ren);
            }
            else if(command[0]=='D')
            {
                int ans=q.front();
                printf("%d\n",team[ans].front());
                team[ans].pop();
                if(team[ans].empty()) //此处判断队列是否为空,非常重要的一部,大多数人队列都会忘记是否判空
                {
                    numgroup[ans]=0;
                    q.pop();
                }
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值