POJ 2259 Team Queue(队列)

Team Queue
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3987 Accepted: 1407

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


题意:有n个小组,要进行排队,当一个人来到队伍时,若队伍中有自己小组成员时,他就直接站到其后面(类似有熟人就插队╰( ̄▽ ̄)╭),如果没有,则站到队伍最后面,形成自己小组的第一个入队元素。 出队列时和普通队列一样,给出入队指令与入队成员号码,再给出出队指令,输出出队成员号码。


题解:这题用可以n个队列(q_teamber[])分别储存每个小组的入队成员,再用一个队列q_teamid储存小组的id。


入队分析:

 当一个元素入队时,先判断这个元素同组成员有没有已经进入队列了,就是判断队列q_teamid中有没有改小组的id,可以用一个nFlag[]数组标记id有没有入队列q_teamid。 如果没有,则将该小组id入队列。 然后将该成员ber入自己小组入队成员的队列q_teamber[i]。  


出队分析:

出队就要简单很多,直接找到储存小组id的队列q_teamid的队首元素,确定队首小组的id,然后在该小组队列q_teamber[i]中将队首成员出队列即可。  当一个小组队列为空时,表示该小组没有成员在id队列q_teamid中了,则将该队伍的id(也就是id队列q_teamid的队首元素)出队列,并将nFlag[i]标记清除。


代码如下


#include<cstdio>
#include<iostream> 
#include<cstring>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;
int case_num=0,n,team_num;
queue<int>q_teamber[1010];//储存每个小组的队列 
queue<int>q_teamid;//储存每个小组id的队列 
int member[1000010];//元素与小组标号的映射 
bool nFlag[1010]; //标记小组是否已经有成员进入队列 


void init()//初始化 
{
	for(int i=0;i<n;++i){
		nFlag[i]=false;
		while(!q_teamber[i].empty())
			q_teamber[i].pop();
	}
	while(!q_teamid.empty())
		q_teamid.pop();
}

void input()
{
	int num,ber;
	for(int i=0;i<n;++i){
		scanf("%d",&num);
		for(int j=0;j<num;++j){
			scanf("%d",&ber);
			member[ber]=i;
		}
	}
}

void solve()
{
	string command;
	int ber;
	printf("Scenario #%d\n",++case_num);
	while(cin>>command&&command!="STOP")
	{
		if(command=="ENQUEUE"){
			scanf("%d",&ber);
			if(!nFlag[member[ber]]){
				q_teamid.push(member[ber]);
				nFlag[member[ber]]=true;
			}
			q_teamber[member[ber]].push(ber);
		}
		else if(command=="DEQUEUE"){
			int id=q_teamid.front();
			printf("%d\n",q_teamber[id].front());
			q_teamber[id].pop();
			if(q_teamber[id].empty()){
				nFlag[id]=false;
				q_teamid.pop();
			}
		}
	}
	printf("\n");
}

int main()
{
	while(scanf("%d",&n)&&n)
	{
		init();
		input();
		solve();
	}
	return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值