Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意:有一头牛,给出位置不会移动,有一个人要去抓这头牛,人的初始坐标给了,他可以向前走一步,也可以向后走一步,还可以直接跳到当前坐标的二倍处,所花的时间都是1;输出他抓到牛所用的最短时间。宽搜。

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=15204

源代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
queue<int> p;
int step[100005];
int vis[100005];
int n,m;
bool let(int u)
{
    if(u<0||u>100000||vis[u])
        return 0;
    return 1;
}
int bfs()
{
    p.push(n);
    while(!p.empty())
    {
        int u;
        u=p.front();
        p.pop();
        if(u==m)
        {
            printf("%d\n",step[u]);
            return 0;
        }
        if(let(u+1))
        {
            step[u+1]=step[u]+1;
            vis[u+1]=1;
            p.push(u+1);
        }
        if(let(u-1))
        {
            step[u-1]=step[u]+1;
            vis[u-1]=1;
            p.push(u-1);
        }
        if(let(u*2))
        {
            step[2*u]=step[u]+1;
            vis[2*u]=1;
            p.push(2*u);
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    bfs();
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值