[hihocoder 1238] Total Highway Distance(微软2016校园招聘9月在线笔试)

描述

Little Hi and Little Ho are playing a construction simulation game. They build N cities (numbered from 1 to N) in the game and connect them by N-1 highways. It is guaranteed that each pair of cities are connected by the highways directly or indirectly.

The game has a very important value called Total Highway Distance (THD) which is the total distances of all pairs of cities. Suppose there are 3 cities and 2 highways. The highway between City 1 and City 2 is 200 miles and the highway between City 2 and City 3 is 300 miles. So the THD is 1000(200 + 500 + 300) miles because the distances between City 1 and City 2, City 1 and City 3, City 2 and City 3 are 200 miles, 500 miles and 300 miles respectively.

During the game Little Hi and Little Ho may change the length of some highways. They want to know the latest THD. Can you help them?

输入

Line 1: two integers N and M.

Line 2 .. N: three integers u, v, k indicating there is a highway of k miles between city u and city v.

Line N+1 .. N+M: each line describes an operation, either changing the length of a highway or querying the current THD. It is in one of the following format.

EDIT i j k, indicating change the length of the highway between city i and city j to k miles.

QUERY, for querying the THD.

For 30% of the data: 2<=N<=100, 1<=M<=20

For 60% of the data: 2<=N<=2000, 1<=M<=20

For 100% of the data: 2<=N<=100,000, 1<=M<=50,000, 1 <= u, v <= N, 0 <= k <= 1000.

输出

For each QUERY operation output one line containing the corresponding THD.

样例输入
3 5
1 2 2
2 3 3
QUERY
EDIT 1 2 4
QUERY
EDIT 2 3 2
QUERY
样例输出
10
14
12

题解:记录每条边需要计算的次数,计算总和。每次改变某条边,将差值更新到总和即可。注意数据范围,一些变量需要long long型!!!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<string>
#include<limits.h>
#include<unordered_map>
#include<map>
#include<stack>
using namespace std;
int n,m;
vector<int> edge[100001];
map<pair<int,int>,long long> Count;
map<pair<int,int>,int> Map;
long long sum;
int dfs(int cur,int f){
	int res=1;
	for(int i=0;i<edge[cur].size();i++) {
		if(edge[cur][i]==f) continue;
		long long t=dfs(edge[cur][i],cur);
		res+=t;
		pair<int,int> p;
		p.first=cur,p.second=edge[cur][i];
		Count[p]=t*(n-t);
		sum+=Count[p]*Map[p];
	}
	return res;
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<n;i++) {
		int s,e,len;
		scanf("%d%d%d",&s,&e,&len);
		edge[s].push_back(e);
		edge[e].push_back(s);
		pair<int,int> tmp;
		tmp.first=s;tmp.second=e;
		Map[tmp]=len;
		tmp.first=e;
		tmp.second=s;
		Map[tmp]=len;
	}
	sum=0;
	dfs(1,-1);
	for(int i=0;i<m;i++) {
		char op[10];
		scanf("%s",op);
		if(strcmp(op,"QUERY")==0) {
			printf("%lld\n",sum);
		}
		else {
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			pair<int,int> tmp;//(a,b);
			tmp.first=a;tmp.second=b;
			if(Count.find(tmp)==Count.end()) {
				tmp.first=b;tmp.second=a;
			}
			sum=sum+(long long)(c-Map[tmp])*Count[tmp];
			Map[tmp]=c;
		}
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值