poj 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 30924   Accepted: 9536

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes

题目大意: 在一个坐标轴上给你点n和点k,设当前点位x,可以有三种方式,x+1或者x-1或者x*2,问最少几步可以打k点;

   直接bfs,搞个队列;

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define MAX 100005
using namespace std;
queue <int>q;
bool visit[MAX];//标记该点是否走过的数组
int step[MAX];//表示到当前点所走的步数的数组
bool pd(int num)//判断当前点是否越界,搜索题必要步骤
{
    if(num<0||num>100000)
        return true;
      return false;
}
int bfs(int st,int ed)
{
    queue<int>q;
    int t,tmp;
    q.push(st);//先将起点入队列
    visit[st]=true;//将起点设置为已经走的
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        for(int i=0;i<3;i++)//对三种方式进行搜索
        {
            if(i==0)
                tmp=t+1;
            else if(i==1)
                tmp=t-1;
            else
                tmp=t*2;
            if(pd(tmp))//判断是否越界
                continue;
            if(!visit[tmp])
            {
                step[tmp]=step[t]+1;//当前点的步数为上一点+1
                if(tmp==ed)//若已到达终点则 返回所走步数
                    return step[tmp];
                visit[tmp]=true;//标记tmp点已走过
                q.push(tmp);
            }
        }

    }
}
int main()
{
   int n,k;
   while(~scanf("%d%d",&n,&k))
   {
       memset(visit,false,sizeof(visit));
       if(n>=k)//如果起点大于终点,则只有一种方式可以选择即x-1
        cout<<n-k<<endl;//所以直接输出两者差值
       else
        cout<<bfs(n,k)<<endl;
   }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值