lightoj 1009 Back to Underworld (种类并查集)

The Vampires and Lykans are fighting each other to death. The war has become so fierce that, none knows who will win. The humans want to know who will survive finally. But humans are afraid of going to the battlefield.

So, they made a plan. They collected the information from the newspapers of Vampires and Lykans. They found the information about all the dual fights. Dual fight means a fight between a Lykan and a Vampire. They know the name of the dual fighters, but don't know which one of them is a Vampire or a Lykan.

So, the humans listed all the rivals. They want to find the maximum possible number of Vampires or Lykans.


Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105), denoting the number of dual fights. Each of the next n lines will contain two different integers u v (1 ≤ u, v ≤ 20000) denoting there was a fight between u and v. No rival will be reported more than once.

Output

For each case, print the case number and the maximum possible members of any race.

Sample Input

2

2

1 2

2 3

3

1 2

2 3

4 2

Sample Output

Case 1: 2

Case 2: 3

Hint

Dataset is huge, use faster I/O methods.


种类并查集。

group[i]代表i和他的祖先的关系,group[i]=1代表是同类,=0代表不是同类。

#include<bits/stdc++.h>
#define N 20000+10
using namespace std;
int f[N],group[N];
int in[N],num[N],flag[N];

int Find(int x)
{
    if(x==f[x])
        return x;
    int tx=f[x];
    f[x]=Find(f[x]);
    group[x]=(group[x]+group[tx]+1)%2;
    return f[x];
}

int main()
{
    int t,m,n,a,b;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&m);
        for(int i=1; i<N; i++)
        {
            f[i]=i;
            group[i]=1;
            in[i]=0;
            flag[i]=0;
            num[i]=1;
        }
        n=-1;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            n=max(a,n);
            n=max(b,n);
            in[a]=1,in[b]=1;
            int ta=Find(a);
            int tb=Find(b);
            if(ta!=tb)
            {
                f[ta]=tb;
                num[tb]+=num[ta];//集合里的元素整体要归到祖先下面
                group[ta]=(group[b]-group[a]+2)%2;
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(in[i])
            {
                int ti=Find(i);
                if(group[i]==0)
                    flag[ti]++;
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++)//计算每一个祖先下面的儿子们与祖先的关系,累加
        {
            if(in[i]&&f[i]==i)
            ans+=max(flag[i],num[i]-flag[i]);
        }
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值