【Lightoj 1009 Back to Underworld】+ 二分图染色

Description
The Vampires and Lykans are fighting each other to death. The war has become so fierce that, none knows who will win. The humans want to know who will survive finally. But humans are afraid of going to the battlefield.

So, they made a plan. They collected the information from the newspapers of Vampires and Lykans. They found the information about all the dual fights. Dual fight means a fight between a Lykan and a Vampire. They know the name of the dual fighters, but don’t know which one of them is a Vampire or a Lykan.

So, the humans listed all the rivals. They want to find the maximum possible number of Vampires or Lykans.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105), denoting the number of dual fights. Each of the next n lines will contain two different integers u v (1 ≤ u, v ≤ 20000) denoting there was a fight between u and v. No rival will be reported more than once.

Output
For each case, print the case number and the maximum possible members of any race.

Sample Input
2
2
1 2
2 3
3
1 2
2 3
4 2
Sample Output
Case 1: 2
Case 2: 3

把可以确定的对立军队二分图染色,依次找出每个对立阵营的最多军队相加即可 :

下面是AC代码 :

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int KL = 20011;
vector <int> v[KL];
int vis[KL],na,nb,ans;
void init(){
    memset(vis,0,sizeof(vis));
  for(int i = 0 ; i <= KL ; i++)
     v[i].clear();
}
void DFS(int x,int y){
    vis[x] = 1;
    if(y == 1) na++;
    else nb++;
    for(int i = 0 ; i < v[x].size(); i ++){
        int u = v[x][i];
        if(!vis[u])
            DFS(u,3 - y); //者 u 为 x 的对立阵营
    }
}
int main()
{
    int T,nl = 0,N,a,b,i;
    scanf("%d",&T);
    while(T--){
        init();
        scanf("%d",&N);
        while(N--){
            scanf("%d%d",&a,&b);
            v[a].push_back(b);
            v[b].push_back(a);
        }
        ans = 0;
        for(i = 1 ; i <= KL ; i++)
            if(!vis[i] && v[i].size()){
                na = nb = 0;
                DFS(i,1);
                ans += max(na,nb); // 每次让军队最多的阵营为同一阵营
        }
        printf("Case %d: %d\n",++nl,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值