Description
A friend is like a flower, a rose to be exact, Or maybe like a brand new gate that never comes unlatched. A friend is like an owl, both beautiful and wise. Or perhaps a friend is like a ghost, whose spirit never dies. A friend is like a heart that goes strong until the end. Where would we be in this world if we didn't have a friend? - By Emma Guest |
Now you've grown up, it's time to make friends. The friends you make in university are the friends you make for life. You will be proud if you have many friends.
Input
There are multiple test cases for this problem.
Each test case starts with a line containing two integers N, M (1 <= N <= 100'000, 1 <= M <= 200'000), representing that there are totally N persons (indexed from 1 to N) and M operations, then M lines with the form "M a b" (without quotation) or "Q a" (without quotation) follow. The operation "M a b" means that person a and b make friends with each other, though they may be already friends, while "Q a" means a query operation.
Friendship is transitivity, which means if a and b, b and c are friends then a and c are also friends. In the initial, you have no friends except yourself, when you are freshman, you know nobody, right? So in such case you have only one friend.
Output
For each test case, output "Case #:" first where "#" is the number of the case which starts from 1, then for each query operation "Q a", output a single line with the number of person a's friends.
Separate two consecutive test cases with a blank line, but Do NOT output an extra blank line after the last one.
Sample Input
3 5
M 1 2
Q 1
Q 3
M 2 3
Q 2
5 10
M 3 2
Q 4
M 1 2
Q 4
M 3 2
Q 1
M 3 1
Q 5
M 4 2
Q 4
Sample Output
Case 1:
2
1
3
Case 2:
1
1
3
1
4
Notes
This problem has huge input and output data, please use 'scanf()' and 'printf()' instead of 'cin' and 'cout' to avoid time limit exceed.
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
int cn[100010];
int cnt[100010];
int find(int f)
{
int k=f;
while (cnt[k]!=k)//寻找祖先,也就是一颗树的根节点
{
k=cnt[k];
}
int i=f,j;
while (i!=k)//压缩路径
{
j=cnt[i];
cnt[i]=k;
i=j;
}
return k;
}
int main()
{
int n,m,i,j,k,tj,tk,fff=1;
char str[2];
while(~scanf("%d %d",&n,&m))
{
if (fff!=1) printf("\n");
printf("Case %d:\n",fff++);
getchar();
for (i=1;i<=n;++i)
{
cnt[i]=i;
cn[i]=1;
}
for (i=1;i<=m;++i)
{
scanf("%s",&str);
if (str[0]=='M')
{
scanf("%d %d",&j,&k);
tj=find(j);tk=find(k);
if (tj!=tk)//祖先不同,也就是不是同一颗树,合并起来
{
<span style="font-family: 'times new roman';"> /*这里想不出来,原本是用ff++,每次拿cn【tk】=ff结果WA了。这里是</span>
<span style="font-family: 'times new roman';"> 如果祖先变了也可将原来的数加回来的意思,因为祖先是随意的 */</span>
cn[tk]+=cn[tj];
cnt[tj]=tk;
}
}
else
{
scanf("%d",&j);
printf("%d\n",cn[find(j)]);
getchar();
}
}
}
return 0;
}