The MAX

The MAX
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F. 
 

Input

Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output

For each test case, output the biggest value of F you can find on a line.
 

Sample Input

     
     
2 1 2 0
 

Sample Output

     
     
4017
 
    这题真是叫人无语了,给的数据值根本就不对,竟然是long long的,不是说10的8次方吗?有这样坑人的水题吗?

AC代码:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	unsigned long long k,j,n,i,a[110];
	while(cin >> n&&n)
	{
		for(i=0,j=0;i<n;++i)
		{
			cin >> a[i];
			j+=a[i];
		}
		sort(a,a+n);
		j-=a[n-1];
		k=a[n-1]*(2009-n+1)+j;
		cout << k << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值